An only requirement to display the PoziTone notifications correctly is Google Chrome version should be 28 or higher.

This article was helpful for 2 people. Is this article helpful for you?